Misdirected Request The client needs a new connection for this request as the requested host name does not match the Server Name Indication (SNI) in use for this connection. Plesk Hatası

Şu tarihte değiştirildi Cum, 5 Eyl şunda: 10:04 PM

Bu hata Plesk panelinde genellikle SNI (Server Name Indication) ile ilgili bir yönlendirme veya SSL sertifikası problemi olduğunda çıkar.
Tarayıcı, sunucuya gönderdiği host adı ile sunucunun SSL/TLS tarafında cevap verdiği host adı uyuşmazsa “Misdirected Request” hatası görürsünüz.

Olası Nedenler

  1. SSL Sertifikası yanlış atanmış:
    İlgili domain için tanımlı SSL yerine farklı bir domainin SSL’i kullanılıyor olabilir.

  2. Plesk default host name hatalı:
    Sunucunun varsayılan host adı (hostname) ile Plesk üzerinden erişilen domain uyuşmuyor.

  3. Reverse proxy (Nginx + Apache) yönlendirmesi:
    Nginx üzerinden geçen istek Apache’ye farklı host name ile aktarılıyorsa uyuşmazlık çıkabilir.

  4. Cloudflare veya CDN kullanımı:
    CDN tarafındaki SSL ile Plesk’teki SSL çakışması olabilir.


Çözüm Yöntemleri

? 1. SSL Sertifikasını Doğru Ata

  • Plesk panelde → Domains → example.com → Hosting & DNS → SSL/TLS Certificates kısmına girin.

  • İlgili domaine doğru sertifikayı atayın.

? 2. Sunucu Hostname’ini Düzenle

  • Plesk panelde Tools & Settings → Server Settings → Full hostname kontrol edin.

  • Buradaki hostname’in geçerli bir DNS kaydı olmasına ve SSL ile uyumlu olmasına dikkat edin.

? 3. Varsayılan SSL Sertifikasını Değiştirin

  • Plesk panelde Tools & Settings → SSL/TLS Certificates kısmında “Certificate for securing Plesk” ayarını kontrol edin.

  • Buraya sunucu hostname’i ile uyumlu SSL sertifikasını atayın.

? 4. Reverse Proxy Yapılandırmasını Kontrol Edin

  • Eğer Nginx aktifse, domainin config dosyasında (/etc/nginx/conf.d/) server_name değerini kontrol edin.

  • Yanlış host yönlendirmesi varsa düzeltin.

? 5. Cloudflare / Proxy Kullanıyorsanız

  • Cloudflare aktifse → SSL/TLS modunu Full (strict) yapın.

  • Sertifikanız Let’s Encrypt ise, Cloudflare tarafında DNS ve proxy ayarlarını kontrol edin.


? Kısacası:
Büyük ihtimalle yanlış SSL atanmış ya da sunucu hostname ile Plesk’in SSL sertifikası uyuşmuyor.

Bu makale sizin için faydalı oldu mu?

Harika!

Geri bildiriminiz için teşekkür ederiz

Üzgünüz! Size yardımcı olamadık

Geri bildiriminiz için teşekkür ederiz

Bu makaleyi nasıl iyileştirebileceğimizi bize bildirin!

Nedenlerden en az birini seçin
CAPTCHA doğrulaması gereklidir.

Geri bildirim gönderildi

Çabanızı takdir ediyoruz ve makaleyi düzeltmeye çalışacağız